Ruger Pistol Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have replaced the LCI I'm my mkiii. It's a older pistol I think not real old but maybe 10+ yrs. My question is when I replaced the lci with VQ ss filler is there a tab or something I needed to take out or is it just a simple remove old lci and install new,? Having some failure to eject and failure to extract. Thanks
 

·
Registered
Joined
·
74 Posts
I have replaced the LCI I'm my mkiii. It's a older pistol I think not real old but maybe 10+ yrs. My question is when I replaced the lci with VQ ss filler is there a tab or something I needed to take out or is it just a simple remove old lci and install new,? Having some failure to eject and failure to extract. Thanks
Were you having failures to eject and extract before you put the VQ filler in your gun? I think the filler is just a plain piece of steel without any tabs that just goes in in place of the old LCI. I took the old LCI out of mine and trimmed the tab off of it and put it back in and it works just fine that way. The MKIII's were sometimes picky on ammo and had some issues feeding and ejecting.

Any idea how many rounds you have shot through yours?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
I have no idea on round count. The problem was before the vq kit. I may have found the problem. Extractor has a rounded corner. My mkii is not that way. Also with a round in chamber main spring latch out for safety. I can pull the bolt back and when the round hits the ejector it just falls free with the mark ii it flings the round out. The extractor doesn't seem to grip the case very strong nothing like the mkii.
My new VQ extractor will be here in a bout 3 more days.
Thanks for the help. I will let you know once I get it checked out after new extractor install.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Installed new VQ extractor and the mkiii seemed ok for about 3 mags then it started not feeding second round. Pull trigger click so it is cocking the hammer. Always second round. No tools with me or another mag. Got home and the mag was pretty rough and dragging. Took mag apart and polished the slot for the pin for follower polished the pins groove 600 wet dry paper. Polished takedown pin. Feels 100% better. Will try again tomorrow evening.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
I could work the bolt with mag loaded with firm grip snd no finger in trigger gaurd. They all loaded fine and ejected great.
I did put some gun slick black grease on the touching pars that moved in the mag.
 

·
Registered
Joined
·
81 Posts
I replaced th LCI on both my pistol just because it was not needed I have never had issues. My pistols run fine with all the ammo I feed it. The original LCI can be ground down, or buy the replacement. it is just a filler piece for the slot. The LCI was a common complaint for may, because in order to work it had to touch the shell which could cause feeding issues etc. Get rid of it. It is not needed at all.
 

Attachments

1 - 7 of 7 Posts
Top