Ruger Pistol Forums banner

21 - 40 of 58 Posts

·
Registered
Joined
·
4 Posts
The pistol arrived.

The sheet sent with it says that the slide assembly and barrel were replaced then test fired with 24 rounds of black hills 100gr ammo with no malfunction.

Time will tell, but pleased with Ruger's quick turnaround and what they did. I was worried they might just try and reinstall an ejector.

This way. starting fresh. Hopefully no more issues.
 

·
Registered
Joined
·
3 Posts
Same issue. Brand new lcpii. Took it to the range the day I bought it and my extractor flew out after about 125 rounds. I found the parts, re-assembled, then lost them after 8 or 9 rounds. This time I was unable to find the spring.

Very disappointed as I bought it to be my daily carry. I will be calling Ruger later today.
 

·
Registered
Joined
·
4 Posts
I gave it to my dealer to ship in. I’ll update when it comes back. What was the turnaround time for those who sent theirs in?
I called Ruger, they emailed me a 2 day FedEx label.....they had it for 2 days and then sent it back via 2-day......

So 6 days (maybe 7) from the day I called them and I had it back.

They do require a 21 or older person to sign for it when it is delivered.....so if you are not home all the time this may not work for you.

The dealer I bought it from was a 90 minute drive away (each way).....probably could have used a more local shop but there would have ben an added charge I am sure....I wanted to avoid the middle man and I knew I would be home.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #28 ·
I had this happen with mine. I allowed Ruger to send me a new spring and extractor. Reinstalled. It worked for a few rounds and back into the universe went the new extractor. Tell Ruger that you expect a new slide and barrel. That's what they did on mine.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
3 Posts
Thanks guys you answered my question I posted separately before I found this thread. See below.

Mine is a LCP classic not an LCP II. I tis a new gun so likely a tolerance issue as you discussed.

I have new parts on the way but expect I will have to send it in for service and new slide etc.


Joe
 

·
Registered
Joined
·
2 Posts
Can't believe I stumbled on this forum, but took my brand new LCPII out of the box this morning, went to the range, 5 rounds into it and the extracting stopped! Guess I was having a major brain fart because I kept pulling out the empty shells by hand, racking in a new round, and it did it again, 3 more times. I was blaming myself for shooting it out of the box without cleaning it first, so I put it to the side and played with my other guns. When I got home and went to lock it away, I found the extractor gone! Ugh, I'll call Ruger tomorrow, just don't feel like dealing with that aggravation through the holidays. Anybody here have problems feeding the mag too? It stops at the mag release button. I push the button in and then it inserts fully.
 

·
Registered
Joined
·
1 Posts
Can't believe I stumbled on this forum, but took my brand new LCPII out of the box this morning, went to the range, 5 rounds into it and the extracting stopped! Guess I was having a major brain fart because I kept pulling out the empty shells by hand, racking in a new round, and it did it again, 3 more times. I was blaming myself for shooting it out of the box without cleaning it first, so I put it to the side and played with my other guns. When I got home and went to lock it away, I found the extractor gone! Ugh, I'll call Ruger tomorrow, just don't feel like dealing with that aggravation through the holidays. Anybody here have problems feeding the mag too? It stops at the mag release button. I push the button in and then it inserts fully.
I am on hold with Ruger now. My LCP 2 was chewing up the recoil spring assembly stop on the frame. Ruger replaced the pistol with a new one. Took it out to the range a couple of weeks ago and with less then 40 rounds fired it stopped ejecting the rounds. Checked, the extractor assembly was gone. Called Ruger and they issued a RMA, just got the pistol back, they replaced the barrel and slide assembly. Just went to the range and ran a box of Winchester 95 grain FMJ through the pistol. Opened up the second box on the 5 round, a total of 55 rounds it stopped ejecting the rounds, sure enough extractor assembly is gone in the dirt. On hold now with Ruger, will update.
 

·
Registered
Joined
·
1 Posts
I was wondering why I couldn't get past the first round successfully. The friggin' extractor is gone!!

How does an extractor just disappear?

On the way back to Ruger...

Is it easy to just drop in another extractor and pin it? Is that all that holds the extractor in is that slide pin behind it? (Pin is gone too).

Sent from my Pixel 3 XL using Tapatalk
Mine did the same thing. Started jamming one trip to range. Took it home cleaned it, couldnt see anything wrong. Went back to range and wouldnt eject a single round. Sat down to look again and complete extractor assm gone !
 

·
Registered
Joined
·
3 Posts
Got my new extractor parts the other day. I installed them and ran a few mags through the gun with no problem. I will keep playing with it to see if it fails again. The obvious problem is that I can' trust it for BUG duties.

I am impressed by how well it shoots. At 10 yards slow fire I can put all 6 in a 3" circle, when I speed up I can still get all A zone hits pretty consistently.
 

·
Registered
Joined
·
2 Posts
I am on hold with Ruger now. My LCP 2 was chewing up the recoil spring assembly stop on the frame. Ruger replaced the pistol with a new one. Took it out to the range a couple of weeks ago and with less then 40 rounds fired it stopped ejecting the rounds. Checked, the extractor assembly was gone. Called Ruger and they issued a RMA, just got the pistol back, they replaced the barrel and slide assembly. Just went to the range and ran a box of Winchester 95 grain FMJ through the pistol. Opened up the second box on the 5 round, a total of 55 rounds it stopped ejecting the rounds, sure enough extractor assembly is gone in the dirt. On hold now with Ruger, will update.
Well, it was a quick turnaround, shipped out and back to my door in 8 days. I am upset though, the woman on the phone at customer service said, "yes, we have had quite a few of these come through". She was nice, but I asked her why they wouldn't issue a recall? I carry this off-duty, like many of you, and can't afford taking a chance of it happening when my life depends on it. and now seeing this, apparently even the fixes aren't helping. Plus, they replaced the slide assembly and put a little note on the repair slip as if it was something I did..."make sure the slide is seated completely forward to avoid this in the future". Really, no Sh..!! I am certain that the gun wouldn't (or at least shouldn't) fire if the slide wasn't seated all the way forward. And if I am going through a mag, is the expectation that I stop after each round and check the slide positioning!!!! I will be sticking to my S&W Performance Center EZ Shield .380. Love that gun, but it was just a little larger than what I wanted, and found, in the LCP II. Looks like I have nothing more than a paperweight on my hand. Sad, very disappointed in Ruger.
 

·
Registered
Joined
·
1 Posts
Adding my issue to this thread (hope thats OK).

Same issue.

303 rounds fired through this, and the last 15 or so we were having ejection issues.

The ejector , spring, pin etc -- all GONE "somewhere".

Glad to have seen this thread as I was gonna try just getting the parts myself. Looks like it would be best to send it to Ruger. Thanks for the info.

Sad to see this issue. It's actually my wife's pistol and she doesnt carry ...just at the range. No abuse. Etc.

All the jamming has freaked her out some.
Same problem after about 300 rounds. At the range extractor gone. I had experienced hesitation loading JHP rounds for about the previous 10-12 magazine reloads. Both 6 and 7 round magazines. Finally saw the video on missing extractor...sending it back to Ruger this week. Last FMJ rounds were about 20 rounds of Aquila 95gr.

Thanks,
John K
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #38 ·
I like the LCP Ii and still carry it after I got the new slide and barrel, but I still worry. When I can find one, I'm buying the 1911-ish Sig P238.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
3 Posts
I got mine back from repair. They replaced basically everything in the slide. A few boxes of ammo later and the extractor just shot out again. At this point I’m convinced that this boils down to poor design as far as I’m concerned and this pistol should be discontinued. I’m taking it to my firearms dealer tomorrow and buying something reliable. Its a shame because ruger is a great company with good products but this one has failed me repeatedly. I will not carry a firearm that I can’t trust my life with.
 

·
Registered
LCP 2
Joined
·
12 Posts
I just got my LCP2 back from Ruger. Eight day turnaround. They put a new slide and barrel on. Now I have to go to the range to see if it holds together. My fingers are crossed.
 
21 - 40 of 58 Posts
Top