Ruger Pistol Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,


I'm a bit of a newbie here but in high hopes that someone can help me out. I watched a few videos online and followed a tutorial to remove the magazine disconnect in my lc9s. Worked like a charm, got everything put back together, put the slide on, cocked it and tried to dry fire....and nothing. The trigger feels stuck like the magazine disconnect is still in there. Worse still, I can't get the slide off bc I cannot fire the trigger! I'm not sure what else to do here or how to even get the slide off to take out the trigger assembly to inspect. Any ideas? Anyone go through something like this and come out on the other side?
 

·
Premium Member
Joined
·
3,812 Posts
Take the pistol to a qualified pistolsmith. Liability issues are going to prevent folks here from troubleshooting your defective pistol without hands-on inspection and the proper skill to repair it.
 

·
Registered
Joined
·
11 Posts
Tell us more. Does the trigger move at all? Can you rack the slide? Does the hammer move when trigger is pulled but won't fire? During reassembly of the trigger housing did you preload that area at the rear? Did you have the rear site off?
 

·
Super Moderator
Joined
·
4,593 Posts
Tell us more. Does the trigger move at all? Can you rack the slide? Does the hammer move when trigger is pulled but won't fire? During reassembly of the trigger housing did you preload that area at the rear? Did you have the rear site off?
+1 toytraindoc
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top