Ruger Pistol Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hi Everybody,
After being on the waiting lists since March, I finally got my LCP (came with two mags) Sept 9th. Took it right into the range from the counter and I was elated! After cleaning it up, went to the range again and it failed after about 50 rounds. Ruger sent me a mailing label and it has been back there for a few days. I really liked it for the short time it was in my possession but it seems to have suffered a trigger problem. Hopefuly all will be fine when it comes back.
I like the idea of a model specific fourm. this is great.
 

·
Registered
Joined
·
68 Posts
Welcome from Ohio. Realy sorry to here about your trigger problem. My first LCP never made it to the range. The Trigger was failed in the box. Your's is the third one that I have been made aware of with a trigger problem. What was your S/N ? Mine was 370-3405. If this is going to become a problem I wonder if Ruger would address it as such. So far my second pistol is working after 50 rounds. I will do some shooting this weekend and I am not incouraged by your news........ :(
 

·
Registered
Joined
·
696 Posts
First off, welcome aboard, secondly, sorry to hear about your LCP, to me its seems like there has been a rash of trigger problems lately. I was one of the lucky ones to get mine right after they came out and the only problem with the bunch was a feeding problem with the last round(fixed with new barrel sent by ruger). Now it seems to be a trigger thing. But dont fear, Ruger will make it all better. Alls well that ends well.
 

·
Registered
Joined
·
263 Posts
Welcome to the forum, hope it comes back 100%. John
 
1 - 5 of 5 Posts
Top